Ут 11 безналичные платежи

Обработка выполнена для слегка измененного релиза УТ 11.1.9.51. Загрузка квитанций Яндекс.Деньги с помощью электронной почты универсальна (в части загрузки писем в табличную часть обработки работает и на БП 3.0, УНФ 1.х — везде для режима управляемых форм). Для создания в УТ 11.1 документов поступления денежных средств по сути важен только один реквизит для учета номера заказа на сайте — по нему идет привязка по оплате.

Дополнительно. Данная задача по автоматизации приема и учета платежей (фактически уже поступивших раз зарегистрированы платежной системой, но еще не проведенных по банковской выписке) хоть и является самостоятельной, но из нее вытекала другая: в момент проведения документов поступления безналичных ДС создавать задачу менеджеру по продажам (или по доставке) и постановке ее в очередь. В такой связке можно оценить степень автоматизации работы фирмы по обслуживанию потребностей клиента.

Формат входной квитанции в письме имеет вид:

2000258290430; 1973; 24880.00

Номер транзакции; Идентификатор клиента (Номер заказа на сайте); Сумма платежа;

Более подробно формат квитанций от Яндекс.Денег приведен ниже, а также включен в макет обработки для тестирования. Привожу строчки из квитанции (специально сделаны ошибки и дубли для тестирования):

2000258290777; 1871; 24880.00; RUB; 24009.20; 28.06.2015 17:06:19; 419991837201967; testfirma.ru; AC;

Учитывая то, что формат сообщений будет часто меняться и, кроме этого, на начальном этапе внедрения потребуется отладка необходимо в подобных случаях заранее подготовиться к отладке. С этой целью я ввел в обработку макет и опцию «off-line» отладки. Нужно просто скопировать в макет текст с квитанцией и включить опцию «Отладка», а в конце отладки провести «генеральную репетицию» приема с e-mail этой же инструкции. Результат в обоих случаях должен быть одинаковым.

Результат работы обработки следующий:

Ниже исходная тестовая информация по заказу клиента (номер заказа на сайте выведен в журнале документов) и конечные результаты работы (включая сообщения об ошибках загрузки — дублируются в журнал регистрации методом глобального контекста ЗаписьЖурналаРегистрации(), т.к. предполагается запуск регламентным заданием для анализа нештатных ситуаций):

Процедура СказатьПользователю(ТекстСообщ) // Если фоновый процесс предусмотреть только в техн. журнал СП = Новый СообщениеПользователю; СП.Текст = ТекстСообщ; СП.Сообщить(); // Журнал регистрации УстановитьПривилегированныйРежим(Истина); ЗаписьЖурналаРегистрации(«ошибка в обоработке ЗагрузкаКвитанцийОтЯндексДенег», УровеньЖурналаРегистрации.Ошибка, , «»+ТекстСообщ, «вывод ошибки»); УстановитьПривилегированныйРежим(Ложь); КонецПроцедуры

Тестовый заказ клиента в УТ 11.1:

Ситуация после загрузки в табличную часть квитанций и также после создания документов.

Общий вид работы.

Результат работы.

Данная задача по интеграции оказалась интересной и сложной по следующим пунктам:

1. Прием писем и их первоначальная обработка встроенными средствами платформы 1С 8.3.6 без использования стороннего почтового клиента с помощью объекта «ИнтернетПочта».

Здесь тоже все не так просто, как кажется: начиная от зависания сеанса 1С во время чтения заголовков переполненного ящика и заканчивая настройкой профиля электронной почты для выяснения настроек портов и протоколов (SSL). В частности, для корректного доступа на pop.rambler.ru нужно включить опцию разрешения доступа сторонним почтовым клиентом, иначе будете получать непонятное сообщение в переводе с английского «некоректный логин или пароль». Также нужно учесть глючность методов ограничения и удаления писемПочта.ПолучитьЗаголовки(СтруктураОтбора):

СтрОтбора = Новый Структура; //СтрОтбора.Вставить(«ПослеДатыОтправления», Дата(2015, 07, 01) ); //СтрОтбора.Вставить(«Прочитанные», Ложь); //СтрОтбора.Вставить(«Новые», Ложь); Заголовки=Почта.ПолучитьЗаголовки(СтрОтбора); Если Заголовки.Количество()=0 Тогда Возврат 0; //Предупреждение(«В почтовом ящике нет входящих сообщений!», ,»Нет сообщений»); КонецЕсли; // Порядок чтения, пометка и удаление с сервера в ТЗ не оговорены! Логично пока не удалять с сервера, но помечать как прочитанные. Читать только непрочненные. Сообщения = Почта.Выбрать(Ложь, Заголовки, Истина); // Не удалять с сервера, но помечать как прочитанные.

2. Обработка полученного письма в формате HTML (иначе парсинг веб-страницы).

Это самый сложный пункт, поэтому кто сталкивался с подобными задачами — большая просьба поделиться опытом и рассказать о подводных камнях парсинга.

Здесь столкнулся с проблемой, что автоматически выделить текст «как есть» на сервере хотя бы с переносами строк очень непростая задача. На клиенте можно использовать Поле HTML-документа, но перерыв весь интернет нашел решение в DOM-технологии для получения из исходного HTML-документа сплошной строки текста без переноса (метод 1С 8.3 Новый ИнтернетПочта):

Для каждого ТекстСообщения Из Сообщение.Тексты Цикл Если ТекстСообщения.ТипТекста=ТипТекстаПочтовогоСообщения.HTML Тогда Попытка //Проеобразуем HTML в сплошную строку //штатными средствами 1С 8.3 без переносов: Построитель = Новый ПостроительDOM; ЧтениеHTML = Новый ЧтениеHTML; ЧтениеHTML.УстановитьСтроку(ТекстСообщения.Текст, ТекстСообщения.Кодировка); // Utf-8 по умолчанию. ДокументHTML = Построитель.Прочитать(ЧтениеHTML); ТекстВходящие = ТекстВходящие + ДокументHTML.Тело.ТекстовоеСодержимое+ВК_ПС; Исключение ПодробныйАнализОшибки = ПодробноеПредставлениеОшибки(ИнформацияОбОшибке() ); СказатьПользователю(«Ошибка при чтении-записи информации из письма «+ПодробныйАнализОшибки); Продолжить; КонецПопытки; ИначеЕсли ТекстСообщения.ТипТекста=ТипТекстаПочтовогоСообщения.ПростойТекст Тогда ТекстВходящие = ТекстВходящие+ТекстСообщения.Текст; Иначе СказатьПользователю(«Поддерживаются только письма в HTML или простом текстовом формате (не размеченные)»); Продолжить; КонецЕсли; КонецЦикла; // Для каждого ТекстСообщения Из Сообщение.Тексты…

В результате получим результат в виде строки без переносов. Самое веселое, что придуманый способ отладки уже основывался на алгоритме перебора строк объекта ТекстовыйДокумент.

Как альтернатива можно попытаться удалить символы тегов из HTML вроде такого метода:

//Удаление html тегов из строки //Код 1C v 8.х RegExp = Новый COMОбъект(«VBScript.RegExp»); RegExp.IgnoreCase = Ложь; //Игнорировать регистр RegExp.Global = Истина; //Поиск всех вхождений шаблона RegExp.MultiLine = Ложь; //Многострочный режим RegExp.Pattern = «<*>»; //Ищем теги HTML стр=RegExp.Replace(стр, «»); //Заменяем все теги на пустоту

Еще был вариант использовать COMОбъект(«htmlfile»), но тут уже задача сильно усложнается в сторону знаний веб-дизайна.

HTML = Новый COMОбъект(«htmlfile»); HTML.Open(«text/html»); HTML.Write(ТекстПисьма); HTMLDocument = HTML.documentElement.document; Сообщить(HTMLDocument.Body.ChildNodes.length); Сообщить(HTMLDocument.getElementsByTagName(«Table»).length); И третий вариант: // Вариант обработки HTML-документа средствами 1С 8 ХТМЛТекст = ТекстПисьма.ПолучитьТекст(); НовыйHTMLДокумент = Новый COMОбъект(«HtmlFile»); НовыйHTMLДокумент.open(«text/html»); НовыйHTMLДокумент.write(ХТМЛТекст); НовыйHTMLДокумент.close(); ТегТела = НовыйHTMLДокумент.all.tags(«BODY»); Для а = 0 По ТегТела.length — 1 Цикл ТегТела.item(а).innerHTML = » |<P><BR><BR><BR> |<HR> |</P> |<P></P>» + ТегТела.item(а).innerHTML; КонецЦикла; ТекстСообщенияДляОтправки = «»; Для а = 0 По НовыйHTMLДокумент.all.length — 1 Цикл Если НовыйHTMLДокумент.all.item(а).tagName = «HTML» Тогда ТекстСообщенияДляОтправки = НовыйHTMLДокумент.all.item(а).innerHTML; КонецЕсли; КонецЦикла;

Думаю так, что универсальный парсинг HTML-документа (в т.ч. и сторонними средствами) нужен тогда, когда структура документа заранее неизвестна и будет часто меняться. Здесь же структура относительно постоянно. Я привязался для разбивке строк к двум символам «двоеточие» в дате письма (13.11.2015 14:32:19), а также к 13-ти значному номеру транзакции в Яндекс.Деньги (и еще к 15-ти значному яндекс-кошельку). Метод чтения примитивный, но действенный:

Функция ЕстьТранзакцияВСтроке(СтрТекста, СтрТранзакция) Пока Истина Цикл Поз = Найти(СтрТекста, «;»); Если Поз=0 Тогда Возврат Ложь; КонецЕсли; ЯндексКошелек = ОставитьВСтрокеТолькоЦифры(Сред(СтрТекста, Поз-15, 15)); Если СтрДлина(ЯндексКошелек)=15 Тогда СтрТекста = Сред(СтрТекста, Поз+1); Продолжить; КонецЕсли; СтрТранзакция = ОставитьВСтрокеТолькоЦифры(Сред(СтрТекста, Поз-13, 13)); Если СтрДлина(СтрТранзакция)=13 Тогда Возврат Истина; // Это кошелек КонецЕсли; СтрТекста = Сред(СтрТекста, Поз+1); КонецЦикла; КонецФункции

3. Создание документов поступления денежных средств на основании заказа клиента.

Здесь задача обычная (хотя вся задача относится к разряду интеграции). Пока не стал самовольничать и вносить в конфигурацию новый реквизит — флаг загрузки обработкой (который нужно скрыть от пользователя и заполнять только этой обработкой программно). Также сама УТ 11.1.9 делает контроль взииморасчетов по заказу и не дает переплатить. В текущей версии оставил как есть. Даже в такой реализации двойной загрузке по оплате от клиента (переплаты) не будет, хотя тут нужно уточнять дополнительно по условиям оплаты:

Процедура СоздатьДокументы() Экспорт // Вопрос по ТЗ: Может создать в пользовательском режиме доп. реквизит (ЗагруженИзЯндексДенег и контроль этой обработкой? // Иначе только стандартный контроль взаиморасчетов по расшифровкам платежа настройками УТ 11.1.9 как сейчас чтоб заказ не был оплачен дважды УстановитьПривилегированныйРежим(Истина); Запрос = Новый Запрос; Запрос.УстановитьПараметр(«ВхТЗ», Квитанции.Выгрузить(, «Загрузить, Загружен, НомерЗаказа») ); Запрос.Текст = «ВЫБРАТЬ | Вх.Загрузить, | Вх.Загружен, | Вх.НомерЗаказа КАК НомерЗаказа |ПОМЕСТИТЬ ВТ |ИЗ | &ВхТЗ КАК Вх | |ИНДЕКСИРОВАТЬ ПО | НомерЗаказа |; | |//////////////////////////////////////////////////////////////////////////////// |ВЫБРАТЬ | Заказ.Ссылка КАК Заказ, | Заказ.Дата КАК ДатаЗаказа, | ВТ.НомерЗаказа КАК НомерЗаказаССайта |ИЗ | Документ.ЗаказКлиента КАК Заказ | ВНУТРЕННЕЕ СОЕДИНЕНИЕ ВТ КАК ВТ | ПО Заказ.НомерЗаказаНаСайте = ВТ.НомерЗаказа |ГДЕ | Заказ.Проведен | И ВТ.Загрузить | И НЕ ВТ.Загружен | |УПОРЯДОЧИТЬ ПО | ДатаЗаказа»; РезультатЗапроса = Запрос.Выполнить(); Если РезультатЗапроса.Пустой() Тогда Возврат; КонецЕсли; Выборка = РезультатЗапроса.Выбрать(); Пока Выборка.Следующий() Цикл ДокЗаказ = Выборка.Заказ; Док = Документы.ПоступлениеБезналичныхДенежныхСредств.СоздатьДокумент(); Попытка Док.Заполнить(ДокЗаказ); Если Док.РасшифровкаПлатежа.СуммаВзаиморасчетов = 0 Тогда Продолжить; // Защита от двойной загрузки оплаты. Оплата по-условию только по одному заказу. КонецЕсли; Док.Дата = ТекущаяДата(); Док.НомерВходящегоДокумента = Выборка.НомерЗаказаССайта; //!!! Тип строка в Поступление ДС, а тут — тип число! Док.ДатаВходящегоДокумента = Док.Дата; // Уточнить. Может брать из квитанции по реестру как и номер входящего документа. Док.Комментарий = «# Создан обработкой загрузки квитанций от Яндекс.Денег по заказу с сайта «+Выборка.НомерЗаказаССайта; Док.Записать(РежимЗаписиДокумента.Проведение, РежимПроведенияДокумента.Неоперативный); // Уточнить про выписку банка. Квитанции.Найти(Выборка.НомерЗаказаССайта, «НомерЗаказа»).Загружен = Истина; // Вопрос про контроль двойной оплаты (будет ли проводиться Поступление ДДС на основании заказа (расшифровка платежа) ?!? Исключение ПодробныйАнализОшибки = ПодробноеПредставлениеОшибки(ИнформацияОбОшибке() ); СказатьПользователю(«Ошибка при записи и проведении «+Док+» на основании «+ДокЗаказ+» Номер заказа с сайта <<«+ Выборка.НомерЗаказаССайта+»>>»+ПодробныйАнализОшибки); КонецПопытки; КонецЦикла; УстановитьПривилегированныйРежим(Ложь); КонецПроцедуры

4. Встроенный отладчик для техподдержки.

Естественно, ничего не заменит тестирования в реальной ситуации, но, возможно, будет так, что работа с почтовым ящиком будет затруднительна (вдруг будут опции удаления писем). Для этого введена опция отладки загрузки. Справка включена в обработку (F1 в помощь).

Если изменился формат или выскакивает ошибка то для отладки проделать следующее:

4.1 На время работ вывести на форму флаг «Отладка» реквизит булево внешней обработки.

4.2 Скопировать текст письма с проблемной квитанцией с почтового ящика как есть.

4.3 Поместить в текстовый макет внешней обработки и сохранить.

4.4 В режиме предприятия под отладчиком установить флаг «Отладка».

Данная обработка с заранее заложенными возможностями отладки «off-line» скопировать текст письма из внешней почтовой программы с реестром платежей в макет обработки как обычный текст письма (без тегов HTML). Результат заполнения табличной части в обоих случаях должен быть одинаковым, т.к. используются общие механизмы.

P.S. Надеюсь, данная методика работы с квитанциями Yandex.Money для планирования входящих платежей от клиентов будет полезна. Жду от Вас замечаний и предложений по данной тематике.

Разнесение банковской выписки в 1С предприятие — Ультрабизнес

7 июня 2012

Разнесение банковской выписки в 1С8: Управление торговым предприятием

Если вы работали в программе 1С 7.7, у вас был один документ «Банковская выписка», в котором отражались все приходы и расходы по безналичным счетам, за каждый день.

В программе 1С8 любой конфигурации (Бухгалтерия, Управление торговым предприятием, Управление производственным предприятием), роль банковской выписки выполняют несколько документов это: «Платежное поручение входящее» и «Платежное поручение исходящее».

Интерфейс Пункт меню
Полный Документы/Денежные средства/Банк

То есть, на каждое движение денег приход или расход должен быть сформирован один документ, если приход денег – «Платежное поручение входящее», если расход денег – «Платежное поручение исходящее».

Платежные поручения можно разносить как вручную (имеет смысл в том случае если очень мало движений по банку) или же загружать выписки с программы клиент банк.

Вопрос: Можно ли разносить банковские поручение автоматически, загружая их с программы «Клиент банк»? Должны ли разработчики, сопровождающие нас это дорабатывать?

Ответ: Да, возможность загрузки выписок с программы клиент банк присутствует во всех версиях 1С8.

Но для ее реализации необходимо обращаться к программистам, потому, что в каждом банке свой формат выгрузки выписок и его нужно адаптировать под программу 1С8, в среднем по деньгам такая процедура стоит от 200 до 600 грн в зависимости от банка. К примеру, в России во всех банках единый формат выгрузки в клиент банках (уже адаптированный под 1С8) и дорабатывать ничего не нужно.

Теперь давайте остановимся на тех возможностях банковских документов, которых в 1с 7.7 не было – это виды операций платежных поручений.

В каждом платежном поручении (входящем или исходящем) в левом верхнем углу документа присутствует кнопка Операция

При нажатии на эту кнопку показывается перечень возможных операций в документе, в зависимости от выбора определенного вида операции будет изменяться сам документ, а также те проводки, которые он будет формировать.

(Например, видом операции оплата поставщику не получится купить валюту :)).

Рассмотрим виды операций документа «Платежное поручение исходящее»:

  • Вид операции «Оплата поставщику» — предназначен для оплат поставщикам средств за товары или услуги.
  • Вид операции «Возврат денежных средств покупателю» предназначен для формирования возврата денег за возвращенный товар или услуги.
  • Вид операции «Расчеты по кредитам и займам с контрагентами» — вид операции используется для гашения ссуд и займов банков или контрагентов.
  • Вид операции «Прочие расчеты с контрагентами» — чаще всего такой вид операции используется для оплат на таможню, пересылки средств между юридическими лицами, входящими в состав нашего предприятия, то есть пересылка средств между всеми кто не является ни поставщиком, ни покупателем.
    Счет бухгалтерского учета 6851.
  • Вид операции «Перечисление налогов/взносов по заработной плате» — вид операции используется для уплаты государственных налогов НДС, Прибыли, ЕСН, НДФЛ.
    Обратите внимание, в случае уплаты зарплатных налогов, в документе должна обязательно присутствовать ведомость по налогам.
  • Вид операции «Перевод на другой счет» — Вид операции предназначен для пересылки денежных средств между несколькими расчетными счетами одной организации.
  • Вид операции «Прочее списание безналичных денежных средств» — вид операции позволяет сразу же после проведения документа отправлять денежные средства в затраты по бухгалтерскому учету. Также этот вид операции некоторые организации использует для уплаты НДС, Налога на прибыль в бюджет.
  • Вид операции «Перечисление заработной платы» — используется для выплаты по банку заработной платы работникам.

Обратите внимание, для этого вида операции платежного поручения обязательна привязка к ведомости на выплату заработной платы.

Вопрос: У нас открыт зарплатный проект в банке, возможна выгрузка с 1С8 данных о выплачиваемых суммах в программу клиент банк?

Ответ: Да возможность выгрузить с 1С8 в клиен7т банк данных по выплачиваемой заработной плате присутствует, но опять же адаптировать ее могут только программисты 1С.

В среднем такая услуга от 300 до 700 грн.

При формировании выписок с программы клиент банк они по умолчанию будут загружаться с видом операции «Оплата поставщику».

Наша задача, после такой загрузки правильно выбрать виды операций, а также в некоторых случаях заплатные ведомости.

Программа, которая загружает выписки, не сможет правильно распознавать виды операций, те которые доступны в 1С8.

Поэтому их нам нужно будет выбирать вручную.

Рассмотрим виды операций документа «Платежное поручение входящее»:

  • Вид операции «Оплата от покупателя» — предназначен для отражения оплаты денежных средств за товары или услуги покупателями.
  • Вид операции «Возврат денежных средств постащиком» — используется при отражении в базе возвратов денежных средств за товары, которые мы возвращаем.
  • Вид операции «Расчеты по кредитам и займам с контрагентами» — вид операции используется получение средств, предоставленных в виде займов контрагентам.
  • Вид операции «Прочее поступление безналичных денежных средств» — зачастую используется для ввода начальных остатков, более подробно об этом можно прочитать в бесплатном курсе/книге по вводу начальных остатков здесь (ССЫЛКА). Также вид операции используется при формировании уставного капитала основателями, или же пополнении его. Или же возврата банком не использованной гривневой суммы при покупке валюты.
  • Вид операции «Прочие расчеты с контрагентами» — данный вид операции используется для отражения оплат с нашими дружественными организациями (входящие в состав предприятия) счет бухгалтерского учета 3771.
  • Вид операции «Покупка продажа валюты» — Вид операции предназначен для зачисления на расчетный счет валютной суммы, при покупке валюты, или же гривневой суммы при продаже.
  • Вид операции «Поступление оплаты по платежным картам» — предназначен для отражения в базе полученных оплат за продажи по платежным картам.
  • Вид операции «Поступление средств от ФСС» — данным видом операции отражается получение оплаты от фонда соцстраха больничных, декретных и.т.д. Обратите внимание, при формировании такого вида оплаты, обязательно должно быть указано заявление на возмещение, в платежном поручении входящем.

Важно выбирать подходящие виды операций для того, чтобы проводки формировались правильно в соответствии с сутью хозяйственной операции. Также обратите внимание, если учет управленческий также ведется в этой базе, платежные документы также влияют и на управленческий учет.

Вопрос: Так а если что то подобное банковской выписки, которая была в 1С 7.7 в 1С8?

Ответ: В 1С8 Банковская выписка существует,

Интерфейс Пункт меню
Полный Документы/Денежные средства/Банк/Выписка банка

но это не документ, который формирует проводки, это механизм сверки прихода и расхода (по уже сформированным платежным поручениям), по безналичным счетам за определенную дату.

Сформировав такую выписку и открыв клиент банк можно без лишних усилий проконтролировать правильность разнесения платежных поручений, сверив приход, расход и конечный остаток на определенную дату.

Купить программу 1С можно здесь www.softmaster.com.ua

Посмотреть, а также ознакомится с нашими самостоятельными курсами по 1С, можно по ссылкам:

В настоящее время в связи с устареванием поддерживаемых форматов обмена документами валютного контроля отправка в банк документов валютного контроля недоступна, поддерживаются валютные платежные поручения и загрузка валютной выписки.

В 1С Управление торговлей 8 реализована возможность прямого обмена (только в режиме 1С:ДиректБанк) с банком валютными операциями, включая выгрузку / загрузку документов:

  • поступления и списания денежных средств в иностранной валюте;
  • конвертации валюты;
  • валютного контроля и подтверждающих документов при совершении валютных операций.

В основу методологии легло действующее законодательстве о валютном регулировании и валютном контроле:

  • Федеральный закон «О валютном регулировании и валютном контроле» с изменениями и дополнениями;
  • Инструкция Банка России «О порядке представления резидентами и нерезидентами уполномоченным банкам подтверждающих документов и информации при осуществлении валютных операций, о единых формах учета и отчетности по валютным операциям, порядке и сроках их представления», вступившая в силу с 01 марта 2018г.

Для начала работы требуется включение функциональной опции НСИ и администрирование – Казначейство — Платежи в валюте и валютный контроль.

При этом в рабочем месте Казначейство – Банк – Безналичные платежи становиться доступной вкладка Документы валютного контроля, использование которой позволяет создавать Справки о подтверждающих документах как самостоятельно, так и с применением помощника.

Одновременно, в справочниках НСИ и администрирование — Организации и Контрагенты появляется возможность заполнения регистрационной информации на английском языке. Для этого в карточке организации или контрагента предусмотрены поля Наименования – Международное (вкладка Общая информация) и Международный адрес для платежей (англ.), вкладка – Адреса, телефоны.

В зависимости от вида платежа: списание или поступление иностранной валюты, к организации предъявляются разные требования в отношении срока предоставления документов валютного контроля в уполномоченный банк, а именно, справка и прилагаемые к ней подтверждающие документы направляются в банк при:

  • списании денежных средств – одновременно с распорядительными документами на перевод иностранной валюты;
  • поступлении денежных средств – не позднее 15 календарных дней с момента зачисления иностранной валюты на банковский счет организации.

Для формирования формы Справки о подтверждающих документах необходимо внести требуемые данные на вкладках Основное и Подтверждающие документы, а также по ссылке Файлы для передачи в банк приложить электронные копии подтверждающих документов (счета, акты, накладные, ГТД, письма в банк и пр.).

При заполнении справки на вкладке Основное указывается:

  • Организация;
  • Банк – уполномоченный банк, выполняющий функции агента валютного контроля;
  • Договор – договор с иностранным контрагентом, по которому осуществляются расчеты;
  • Дата справки;
  • Файлы для передачи в банк – гиперссылка для перехода в окно добавления присоединенных файлов.

На вкладке Подтверждающие документы вносится:

  • Информация о подтверждающем документе – номер, дата, из списка выбирается тип данных;
  • Код вида документа – выбирается из предопределенного списка;
  • Сумма и Валюта документа;
  • Сумма в валюте договора;
  • Признак поставки — выбирается из предопределенного списка;
  • Ожидаемый срок в формате дата;
  • Страна грузополучателя (грузоотправителя) – выбирается из классификатора стран мира;
  • Признак корректировки;
  • Примечание.

После проведения документа Справка о подтверждающих документах формируется его печатная форма. Для упрощения процедуры заполнения полей справки рекомендуется воспользоваться Помощником создания справок о подтверждающих документах.

В ситуации, когда организация — участник расчетов с зарубежным партнером является получателем платежа в иностранной валюте, поступление денежных средств на транзитный счет организации, помимо распоряжения на перевод со стороны партнера, подтверждается документом Уведомление о зачислении валюты.

Данное уведомление оформляется специалистом банка и может быть загружено в информационную базу из рабочего места Казначейство – Банк – Безналичные платежи в процессе сеанса прямого обмена с банком по команде 1С:ДиректБанк – Синхронизировать с банком.

Как уже было отмечено ранее, при поступлении на счет организации денежных средств в иностранной валюте, законодательство устанавливает срок (15 календарных дней с даты зачисления средств на транзитный валютный счет) для предоставления в банк документов, подтверждающих платеж.

С целью контроля указанного срока в подсистеме Казначейство реализован механизм автоматического создания соответствующих служебных заданий в списке Текущие дела на Начальном экране. При этом денежные переводы, по которым был нарушен срок отправки документов в банк, группируются в отдельном перечне, выделенном красным цветом.

Первоначально, зачисление иностранной валюты, поступившей от зарубежного контрагента, возможно только на транзитный валютный счет организации.

Добавление информации об имеющемся у организации транзитном счете в справочник НСИ и администрирование – НСИ – Банковские счета возможно как, непосредственно из самого справочника по команде Создать, так и из карточки расчетного (текущего) счета в иностранной валюте по ссылке Транзитный. Для заполнения реквизитов банка на английском языке требуется их редактирование в классификаторе НСИ и администрирование – См. также – Банки.

Далее, требуется выполнение процедуры обязательной продажи валюты, в результате которой осуществляется перевод денежных средств с транзитного счета на текущий, а основанием для создания Списания безналичных денежных средств с типом документа Распоряжение об обязательной продаже служит Уведомление о зачислении валюты. Конвертация иностранной валюты, при этом, осуществляется с использованием отдельного документа с одноименным видом хозяйственной операции.

Поскольку, исполнение банком большинства валютных операций связано с получением и проверкой основания для их проведения, со стороны организации возникает необходимость предоставления в банк первичных документов, подтверждающих правомерность совершаемых операций. С этой целью при формировании платежей в иностранной валюте, в документах Списание безналичных денежных средств доступно заполнение следующих данных о:

  • способе взимания банковской комиссии и дополнительных инструкциях банку в отношении платежа – вкладка Основное;
  • коде валютной операции, с возможностью добавления присоединенных файлов по ссылке Файлы для передачи в банк – вкладка Валютный контроль.

Аналогично документам списания безналичных денежных средств, ввод данных о способе оплаты комиссии и инструкциях банку, возможен при создании в иностранной валюте документа Заявка на расходование денежных средств.

С целью пополнения остатка рублевого расчетного счета организации не редко прибегают к операциям продажи иностранной валюты за рубли РФ. Для этого предусмотрен документ Списание безналичных денежных средств — Конвертация валюты, при заполнении, которого, доступен выбор курса конвертации и счета взимания комиссии за совершаемую банком валютно-обменную операцию.

В списке платежей показаны входящие и исходящие платежные документы.

Входящие платежные документы (Приход):

  • Входящий платеж;
  • Приходный ордер.

Исходящие платежные документы (Расход):

  • Исходящий платеж;
  • Расходный ордер.

Входящий платеж и исходящий платеж служат для изменения баланса на расчетных счетах организации, то есть используются для учета безналичных платежей. Приходный ордер и расходный ордер учитывают наличные платежи, то есть изменяют баланс в кассе организации.

Как привязать платежные документы

Платежные документы можно привязать сразу к нескольким товарным документам (заказ, счет, отгрузка, приемка и т.д.). Вы можете определить сумму оплаты для каждого привязанного документа.

  1. Перейдите в список платежей: Деньги — Платежи.
  2. Откройте платеж и нажмите кнопку Привязать платеж. Откроется окно привязки платежа.
  3. Отметьте флажками документы, к которым нужно привязать платеж. Нажмите кнопку Привязать.
  4. Сохраните документ. Для этого нажмите кнопку Сохранить.

Отвязать платеж от документа можно в любой момент. Для этого наведите курсор на документ который вы хотите отвязать и нажмите на «крестик» в конце строки.

Под документом показаны привязанная и непривязанная суммы. Если вы добавляете новые документы, то доступная сумма распределяется между ними по порядку.

Когда доступная сумма платежа достигает отрицательного значения, она подсвечивается красным. В этом случае часть привязанных документов не будет оплачена.

При нажатии на кнопку Перераспределить сумму платежа вся доступная сумма автоматически распределяется между привязанными документами: максимально возможная сумма — на верхний в списке документ, далее — сверху вниз по списку.

Обмениваться с банком можно двумя способами:

1.Обмен файлами

2.Обмен через DirectBank

Обмен файлами

Рассмотрим обмен файлами на примере бухгалтерии предприятия 3.0.

Необходимо открыть раздел «Банк и касса» и войти в подраздел «Банковские выписки».

Развернув кнопку «Еще» следует выбрать «Обмен с банком».

В открывшейся форме есть функции «Отправка в банк» и «Загрузка из банка», следует выбрать нужную.

Далее есть возможность выбрать банковский счет и период, за который необходимы документы.

Рассмотрим функцию выгрузки.

После выбора необходимых параметров следует пометить галочкой документы для выгрузки и нажать на «…» в поле. Откроется проводник, здесь можно указать имя файла и путь для его сохранения (ts_login это облачный диск W, именованные диски и папки проброшены с Вашего компьютера). Далее следует нажать «Сохранить» и «Выгрузить».

Файл успешно выгружен, его можно загружать в 1С.

По умолчанию в 1С внедрен механизм защиты выписки, файл существует пока отрыто окно защиты, если его закрыть файл будет удален.

Данный механизм создан с целью обезопасить банковские документы от подмены или прочего взаимодействия из вне, но если он доставляет неудобства, то его можно отключить, для этого следует нажать на кнопку «Настройка» и снять галочку с пункта «Безопасность обмена с банком».

После открытия данной настройки следует выбрать «…» название программы, для большинства банков подходит формат «Система Клиент-Банк BClient», если формат не подходит или Вашей программы нет с списке, то данный вопрос следует уточнить, обратившись в техподдержку Вашего банка.

Загрузка выписок происходит аналогично. Следует по нажать на кнопку «…» и выбрать файл, выгруженный из клиент-банка, находящийся на диске W (ts_login) или на Вашем локальном ПК, далее «Открыть» и «Загрузить».

Обмен через DirectBank

DirectBank – технология, позволяющая отправлять документы в банк и получать документы из банка непосредственно из программ системы «1С:Предприятия», нажатием одной кнопки в программе «1С». В отличие от технологии Клиент-Банк не требуется установка и запуск дополнительных программ на клиентский компьютер; технология позволяет избежать выгрузки документов в промежуточные файлы. (Материал с сайта https://v8.1c.ru)

Подробнее ознакомиться с данной функцией можно на сайте 1С:https://v8.1c.ru/edi/edi_app/bank/ .

Также по данной ссылке можно ознакомиться со списком банков, поддерживающих технологию.

По вопросам возможности, стоимости и порядка подключения прямого обмена следует обратиться в ваше банковское отделение. Если возможность подключить DirectBank есть, то следует войти в раздел «Администрирование» и выбрать «Обмен электронными документами».

Далее «Обмен с банками», следует выставить галочку «Сервис 1С:ДиректБанк» и открыть «Настройки обмена с банками».

«Создать» и «Далее».

В следующем окне мастера из справочника банков выбирается нужный Вам банк.

В последующих окнах выбирается способ аутентификации в банке (его должны уточнить в вашем банке).

Подробную инструкцию по настройке ДиректБанк банки обычно размещают на своих сайтах, либо её следует запросить, обратившись в техническую поддержку Вашего банка.

Обмен может проходить с использованием ЭЦП или по логину паролю (в том числе с подтверждением через СМС). После успешных настройки и теста обмена можно отправлять и принимать документы из банка.