Недопустимое значение параметра параметр номер 2

Недопустимое значение параметра (параметр номер ‘2’)

Я
   nnnikolay

Помогите пожалуйста заставить работать документ «Приходная накладная» с подхватом цен из регистра сведений «ЦеныТоваровВПрайсеПоставщика».

Ссылка на базу: https://drive.google.com/open?id=0B5he0Ap0fC64TkdSYld2Rm43S00

Буду невероятно благодарен тем, кто поможет исправить ошибку. Уже несколько дней парюсь с этим документом, вечно что-то не так, а сдавать уже совсем скоро. help *crying*.

 
 

   Рэйв

Сколько?

   eklmn

Открой конфигуратор, найди строку с ошибкой и выложи сюда. Надо учиться, а не ждать пока  другие за тебя сделают.

   nnnikolay (2) {ОбщийМодуль.РаботаСоСправочниками.Модуль(4)}: Ошибка при вызове метода контекста (ПолучитьПоследнее)          ЗначенияРесурсов = РегистрыСведений.ЦеныТоваровВПрайсеПоставщика.ПолучитьПоследнее(АктуальнаяДата, Отбор); по причине: Недопустимое значение параметра (параметр номер ‘2’) Недопустимое значение параметра (параметр номер ‘2’)    patapum

(3) похоже, нужно купить СП

   SadrArt

(3) а что в «Отбор»е?

   eklmn

(3) а теперь покажи как отбор формируется

   nnnikolay (5)     Функция РозничнаяЦена(АктуальнаяДата,ЭлементПрайсыПоставщиков)Экспорт          Отбор=Новый Структура («Цена», ЭлементПрайсыПоставщиков); ЗначенияРесурсов = РегистрыСведений.ЦеныТоваровВПрайсеПоставщика.ПолучитьПоследнее(АктуальнаяДата, Отбор);          Возврат ЗначенияРесурсов.Цена;      КонецФункции    nnnikolay

делаю этот КП под руководством преподавателя, она говорит такая ошибка у многих и сама не знает как ее решить

так что на вас вся надежда 😉

   eklmn

что такое ЭлементПрайсыПоставщиков?

   eklmn

и структуру регистра сведений покажи

 
 

   GROOVY

Ведущий

Вангую. Или измерение не «Цена» называется, или оно там не одно.

   GROOVY

Ведущий

Точно там измерения «Цена» нет, судя по возвращаемому значению функции.

   nnnikolay

(9) это справочник, из которого я выбираю товар, а к нему, из регистра сведений должна подставляться цена. это все происходит в документе «приходная накладная» и еще сумма должна считаться.

структура регистра ЦеныТоваровВПрайсеПоставщика:
измерения — Товар
ресурсы — Цена

   GROOVY

Ведущий

(13)  Тогда нафига отбор по цене делать пытаетесь? Синтаксис-помощник кто-то там у вас читать умеет?

Отбор=Новый Структура («Товар», ЭлементПрайсыПоставщиков);    nnnikolay (14) исправил на «Товар», запускаю конфигурацию, документ, выбираю товар, и на моменте когда по сути должна подставляться цена из регистра вылетает ошибка «Ошибка отображения типов: Отсутствует отображение для типа ‘ДанныеФормыЭлементКоллекции’

Если подробно, то:

{Документ.ПриходнаяНакладная.Форма.ФормаДокумента.Форма(19)}: Ошибка при вызове метода контекста (РассчитатьСумму)     РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);по причине:
Ошибка при вызове серверного метода.
по причине:
Ошибка передачи данных между клиентом и сервером. Значение недопустимого типа.
по причине:
Ошибка преобразования данных XDTO:
Запись значения свойства ‘param’:
    форма: Элемент    имя: {http://v8.1c.ru/8.2/managed-application/modules}param
по причине:
Ошибка отображения типов:
Отсутствует отображение для типа ‘ДанныеФормыЭлементКоллекции’

   eklmn

(15) покажи модуль РаботаСДокументами.РассчитатьСумму

   ЧеловекДуши (0) ссылку кинул авторизованную. Вы хоть немного отражайте, что кидаете 🙂

Требуется разрешение Хотите просмотреть файл? Свяжитесь с его владельцем или войдите в аккаунт с правом доступа. Подробнее… А оно мне надо? 🙂    ЧеловекДуши

(15) Попробуй понять, Что есть сервер, и что есть Клиент 🙂
Какие данные можно передать на сервер и Клиенту.
Запусти отладчик, он вам подскажет 🙂

   ЧеловекДуши

(16) Да ТС не понимает, почему нельзя просто так работать с реквизитами формы на сервере 🙂

   eklmn

(19) в том то и дело, надо ж подсказать ))

   eklmn

мы тут уже учительницу нагнули я так понял ))

   nnnikolay

Всё, спасибо всем, особенно ЧеловекуДуши и GROOVY.

Да, причина была в том что «цена» вместо «товар» и общий модуль «РаботаСДокументами» стоял на сервере.

Храни вас 1c:бог 🙂

   GROOVY

Ведущий

(22)  Я 1С-Атеист.

Наведи порядок в своей работе используя конфигурацию 1C «Управление IT-отделом 8»

ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку «Обновить» в браузере.

Недопустимое значение параметра (параметр № 2). Что это и как исправить?

Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.

Заполнение справочника… Ошибка ЗаполнитьЗначенияСвойств

Я
   mataranga &НаСервере
   
Функция СоздатьНовогоФайла(СтруктураФайла) НовыйФайл = Справочники.Файлы; тк = НовыйФайл.СоздатьЭлемент(); Попытка ЗаполнитьЗначенияСвойств(тк,СтруктураФайла); Возврат 1; Исключение Возврат 0; КонецПопытки; КонецФункции \\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\

ЗаполнитьЗначенияСвойств(тк,СтруктураФайла) {(1,1)}: Обращение к процедуре как к функции (ЗаполнитьЗначенияСвойств) В чем ошибка?
 
     Нуф-Нуф

{(1,1)} — ни о чем не говорит?

   mataranga 🙁 НЕТ Функция СоздатьНовогоФайла(СтруктураФайла) НовыйФайл = Справочники.Файлы.СоздатьЭлемент(); //тк = НовыйФайл.СоздатьЭлемент(); Если ЗаполнитьЗначенияСвойств(НовыйФайл,СтруктураФайла) Тогда Возврат 1; Иначе Возврат 0; КонецЕсли; КонецФункции \\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\
{Форма.Форма.Форма(258,6)}: Обращение к процедуре как к функции (ЗаполнитьЗначенияСвойств) Если <<?>>ЗаполнитьЗначенияСвойств(НовыйФайл,СтруктураФайла) Тогда (Проверка: Сервер)    mataranga

Где то глупая ошибка…

Недопустимое значение параметра (параметр номер ‘2’)

подскажите пожалуйста…

   mataranga ГОСПОДИ
Функция СоздатьНовогоФайла(СтруктураФайла) НовыйФайл = Справочники.Файлы.СоздатьЭлемент(); //тк = НовыйФайл.СоздатьЭлемент(); ЗаполнитьЗначенияСвойств(НовыйФайл,СтруктураФайла); Если 1=1 Тогда КонецЕсли; КонецФункции Сработало… только выдало другую ошибку
\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\

{Форма.Форма.Форма(258)}: Ошибка при вызове метода контекста (ЗаполнитьЗначенияСвойств) ЗаполнитьЗначенияСвойств(НовыйФайл,СтруктураФайла); по причине:
Ошибка установки значения свойства ‘Владелец’
по причине:
Справочник не имеет владельца Но это уже мой геморой

   zladenuw

а что в СтруктураФайла передаешь ?
ЗаполнитьЗначенияСвойств в СП прочитай что она делает.

   mataranga

http://pikucha.ru/iaYWO    Это куда передаю
http://pikucha.ru/iaYWR    Что передаю

   mataranga Даже если в Стандартных реквизитах выставляю Владелец — > Проверка заполнения —> Не проверять Все равно пишет {Форма.Форма.Форма(258)}: Ошибка при вызове метода контекста (ЗаполнитьЗначенияСвойств) ЗаполнитьЗначенияСвойств(НовыйФайл,СтруктураФайла); по причине:Ошибка установки значения свойства ‘Владелец’
по причине:
Справочник не имеет владельца    НЕА123

(7)
убей Владелец в СтруктураФайла.

   hhhh

(7) ну, четвертый параметр используй в ЗаполнитьЗначенияСвойств. Чего ты паришься?

   НЕА123

(9)
про него-то я и забыл.
(9)+1

 
 

   mikecool

СоздатьНовогоФайла — бугагашки

   mataranga Функция СоздатьНовогоФайла(СтруктураФайла) НовыйФайл = Справочники.Файлы.СоздатьЭлемент(); Попытка ЗаполнитьЗначенияСвойств(НовыйФайл,СтруктураФайла,,»Владелец»); Возврат 1; Исключение Возврат 0; КонецПопытки КонецФункции \\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\
Если СоздатьНовогоФайла(НовыйФайл) = 0 Тогда Сообщить(«Не удалось создать новый файл…»); Иначе УстановитьПараметрыСеанса(ЭтаФорма.Путь); Сообщить(«Загрузка прошла успешно…»); КонецЕсли; ————————————————-
Пишет что успешно загружен…
Но если лезу консолькой вытаскивать справочник файлы…
он пустой…    drcrasher

записывать не надо?

   НЕА123 Функция СоздатьНовогоФайла(СтруктураФайла) НовыйФайл = Справочники.Файлы.СоздатьЭлемент(); Попытка ЗаполнитьЗначенияСвойств(НовыйФайл,СтруктураФайла,,»Владелец»); НовыйФайл.Записать(); Возврат Истина; Исключение Возврат Ложь; КонецПопытки КонецФункции \\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\
Если СоздатьНовогоФайла(НовыйФайл) Тогда Сообщить(«Не удалось создать новый файл…»); Иначе УстановитьПараметрыСеанса(ЭтаФорма.Путь); Сообщить(«Загрузка прошла успешно…»); КонецЕсли;    НЕА123 *
Если НЕ СоздатьНовогоФайла(НовыйФайл) Тогда    mataranga

Я тоже по отладчику уже пошел увидел эту ошибку 🙂
Спасибо всем большое…
Простите за потраченое время

Наведи порядок в своей работе используя конфигурацию 1C «Управление IT-отделом 8»

ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку «Обновить» в браузере.

Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.

Библиотека стандартных подсистем. Версия 2.1.3 51 . Информация об ошибках

 
  Код ошибки: 10127433  
  Дата публикации: 22 мая 2013 г.  
  Описание: Неверное оповещение о возможности снятия блокировки в локальном режиме работы при запуске под полноправным пользователем с ключом /UC  
 
  Код ошибки: 10129246  
  Дата публикации: 17 мая 2013 г.  
  Описание: При использовании «напоминаний пользователя» в некоторых случаях может возникать ошибка:
«Недопустимое значение параметра (параметр номер ‘2’) «
 
  Способ исправления: В модуле формы «ФормаОповещения» регистра сведений «НапоминанияПользователя» в процедуре ОбновитьТаблицуНапоминаний найти строку:
Интервал = Мин(Интервал, ВремяБлижайшего — ОбщегоНазначенияКлиент.ДатаСеанса());
и заменить на:
Интервал = Макс(Мин(Интервал, ВремяБлижайшего — ОбщегоНазначенияКлиент.ДатаСеанса()), 1);
 
 
  Код ошибки: 10129435  
  Дата публикации: 17 мая 2013 г.  
  Описание: Признак «Ведущее» не установлен для измерения «Учетная запись» регистра сведений «ИдентификаторыПолученныхЭлектронныхПисем»  
 
  Код ошибки: 10125596  
  Дата публикации: 14 мая 2013 г.  
  Описание: Закрывается программа при выполнении синхронизации данных в АРМ (при завершении работы), если получено обновление конфигурации.  
 
  Код ошибки: 10129239  
  Дата публикации: 14 мая 2013 г.  
  Описание: Иногда при загрузке данных в подчиненном узле распределенной ИБ может возникать ошибка вида: «Поле объекта не обнаружено (ДополнительныеСвойства)».  
  Способ исправления: В модуле обработчика КонвертацияОбъектовРаспределенныхИнформационныхБаз в процедуре ПрочитатьИдентификаторыОбъектовМетаданных надо вместо кода
Данные.ДополнительныеСвойства.Вставить(«ЗагрузкаПараметровРаботыПрограммы»);
вставить код:
Если ТипЗнч(Данные) <> Тип(«УдалениеОбъекта») Тогда

Данные.ДополнительныеСвойства.Вставить(«ЗагрузкаПараметровРаботыПрограммы»);

КонецЕсли;

 
  Причина возникновения: Получение удаления элемента справочника «ИдентификаторыОбъектовМетаданных».  
 
  Код ошибки: 10129023  
  Дата публикации: 7 мая 2013 г.  
  Описание: При обновлении конфигурации после того, как изменено имя администратора, возникает ошибка обновления.  
 
  Код ошибки: 10128711  
  Дата публикации: 30 апреля 2013 г.  
  Описание: При запуске автономного рабочего места может возникать ошибка вида:
«Из главного узла не загружены изменения справочника «»Идентификаторы объектов метаданных».
 
  Способ исправления: 1. В общем модуле ОбменДаннымиСервер в процедуре ВыполнитьОбменДаннымиДляУзлаИнформационнойБазыЧерезФайлИлиСтроку
после строки
ПрочитатьСообщениеСИзменениямиДляУзла(СтруктураНастроекОбмена, ПолноеИмяФайлаСообщенияОбмена, СообщениеОбмена);
вставить код
// {Обработчик: ПослеЧтенияСообщенияОбмена} Начало
СтандартнаяОбработка = Истина;

ПослеЧтенияСообщенияОбмена(
СтруктураНастроекОбмена.УзелИнформационнойБазы,
ПолноеИмяФайлаСообщенияОбмена,
РезультатВыполненияОбменаВыполнено(СтруктураНастроекОбмена.РезультатВыполненияОбмена),
СтандартнаяОбработка);
// {Обработчик: ПослеЧтенияСообщенияОбмена} Окончание

2. Исправление ошибки вступит в силу только через одно обновление.

 
  Способ обхода: Инструкция для пользователей:
1. Запустить АРМ (локальную базу на своем компьютере).

v8: Структура

Важно: Конфигуратор для АРМ не должен быть запущен!
2. При запуске, если появится окно параметров подключения, то необходимо проверить правильность задания имени пользователя и пароля. Также должен быть установлен флажок «Запомнить пароль».
3. После ввода необходимых значений следует нажать на кнопку «Проверить подключение». При правильно введенных значениях, если сайт https://1cfresh.com доступен, должно появиться сообщение об успешном подключении.
4. Если подключение произошло успешно необходимо в форме нажать на кнопку «Записать и закрыть».
5. После этого необходимо подождать около 30 минут, пока программа получит обновление из Интернета.
6. После получения обновления может понадобиться запустить базу АРМ в режиме конфигуратора, открыть конфигурацию – меню «Конфигурация» ->> «Открыть конфигурацию» и выполнить команду в меню «Конфигурация» ->> «Обновить конфигурацию баз данных (F7)».
7. Затем можно запустить АРМ в режиме предприятия. После выполнения обработчиков обновления работа с программой будет доступна.
8. Если появится сообщение о неудачном обновлении базы, то его надо проигнорировать.

      Код ошибки: 10127986     Дата публикации: 18 апреля 2013 г.     Описание: При загрузке данных области в пустую ИБ возникает ошибка.     Способ исправления: В модуль ВариантыОтчетов, в процедуру ПриФормированииСловаряЗаменПоКаталогуВыгрузки добавить строку
СтрокаФрагмента.СтандартнаяОбработка = Ложь;
В модуле ВыгрузкаЗагрузкаДанных
В процедуру ПодготовитьФрагментСловаряЗамен
после строки
Результат.Колонки.Добавить(«СоответствиеСсылок», Новый ОписаниеТипов(«Соответствие»));
добавить строку
Результат.Колонки.Добавить(«СтандартнаяОбработка»);
В процедуру ДобавитьФрагментВСловарьЗамен
после строки
СтрокаСловаря.СоответствиеСсылок = СтрокаФрагмента.СоответствиеСсылок;
вставить строку
СтрокаСловаря.СтандартнаяОбработка = СтрокаФрагмента.СтандартнаяОбработка;       Код ошибки: 10126837     Дата публикации: 5 апреля 2013 г.     Описание: При одновременной работе с несколькими внешними отчетами и обработками, может возникать ошибка «Неизвестный идентификатор формы».     Способ воспроизведения: Возникает, когда внешние объекты имеют одинаковое имя объекта метаданных.     Способ обхода: Присвоить внешним объектам различные имена объектов метаданных.       Код ошибки: 10124257     Дата публикации: 2 апреля 2013 г.     Описание: Удаление помеченных объектов не может выполняться в фоне.     Причина возникновения: Удаление помеченных объектов требует установки монопольного режима, который подразумевает один сеанс, работающий с программой.
Выполнение в фоне требует запуска фонового задания, что подразумевает как минимум два сеанса — само фоновое задание и родительский сеанс, из которого было запущено фоновое задание.       Код ошибки: 10124769     Дата публикации: 5 марта 2013 г.     Описание: В РИБ неверно записывается история версий объектов.     Способ обхода: Исключить из состава планов обмена типа «РИБ» регистр сведений ВерсииОбъектов, чтобы вести историю версий независимо во всех узлах.       Код ошибки: 10090855     Дата публикации: 1 ноября 2011 г.  

  Описание: При обмене через внешнее соединение (прямое подключение к базе-корреспонденту) может возникать ошибка:
«{ОбщийМодуль.ОбменДаннымиСервер.Модуль(818)}: Ошибка при вызове метода контекста (ВыполнитьВыгрузкуДанных)
ОбработкаОбменаДаннымиВнешнееСоединение.ВыполнитьВыгрузкуДанных(ОбработкаДляЗагрузкиДанных);
по причине:
Неизвестная ошибка»     Способ обхода: Настроить обмен данными через любой другой доступный вид транспорта, например, через сетевой каталог или FTP.
Выполнить несколько итераций обмена на стороне первой базы и второй базы.
Переключить обмен данными обратно, на обмен через внешнее соединение.     Причина возникновения: Нехватка ресурсов системы при выгрузке документов с большими табличными частями (более 20 000 строк).       Код ошибки: 20007146     Дата публикации: 10 августа 2012 г.     Описание: В подсистеме «Работа с файлами» при открытии карточки файла с помощью клавиши F2 может возникать ошибка «Неверный формат хранилища данных» в режиме «клиент-сервер» («толстый» клиент, Управляемое приложение).       Код ошибки: 10080974     Дата публикации: 13 мая 2011 г.     Описание: При обмене данными в момент загрузки данных документы, введенные на основании, могут не проводиться.
Например, если в базе-источнике ввели два документа Д1, Д2, при этом Д1 является основанием для Д2, то при загрузке данных в базе-приемнике документ Д2 может оказаться непроведенным.     Способ исправления: Использовать правильный хронологический порядок ввода документов: дата документа-основания должна быть раньше даты документа, вводимого на основании.     Способ обхода: Использовать помощник интерактивного обмена данными. В помощнике самостоятельно управлять порядком загрузки документов по типам.       Код ошибки: 10071121     Дата публикации: 1 марта 2011 г.     Описание: В подсистеме Управление доступом, при использовании
а) шаблона ограничения доступа #ПоНаборамЗначений, возможно изменить доступный объект на недоступный;
б) при использовании ограничения по реквизиту табличной части в шаблонах #ПоЗначениямРасширенный и #ПоЗначениямИНаборамРасширенный, результат проверки нового значения реквизита — всегда разрешено.
Необходимо иметь в виду эту особенность поведения при разработке ограничений доступа.     Причина возникновения: Особенность поведения платформы, начиная с версии 8.2.12
Для реквизитов шапки выполняется проверка ограничения изменения и для старых, и для новых значений.
Для реквизитов табличных частей выполняется проверка ограничения изменения только для старых значений.    

Ошибка при вызове метода контекста (РеквизитФормыВЗначение) 1С 8.3 внешняя обраб

Я
   zhukovia Имеется внешняя обработка в 1С 8.3 Пытаюсь получить макет из этой обработки
&НаСервере Процедура СформироватьФайлДляИФНСНаСервере(ФайлИФНС)    ТекстВыгрузки = Новый ТекстовыйДокумент();    ОбъектОбработки = РеквизитФормыВЗначение(«Объект»);    Макет = ОбъектОбработки.ПолучитьМакет(«ФайлИФНС»);
но получаю ошибку
{Форма.Форма.Форма(87)}: Ошибка при вызове метода контекста (РеквизитФормыВЗначение)     ОбъектОбработки = ЭтаФорма.РеквизитФормыВЗначение(«Объект»); по причине: Недопустимое значение параметра (параметр номер ‘1’)
В чем может быть ошибка?
 
 

   zhukovia Точнее ошибка такая
ОбъектОбработки = РеквизитФормыВЗначение(«Объект»)
а не
ОбъектОбработки =ЭтаФорма.РеквизитФормыВЗначение(«Объект»)    Lexey_

(0) ну, например, если в слове «Объект» какая-то буква в английской раскладке

   Cyberhawk

Покажи ошибку на картинке

   zhukovia

(3) В каком смысле на картинке? Я привел полный тест ошибки. (2) Нет все в русской.

   zhukovia

(2) Более того если этот код выставить в другую обработку то все работает.

   Записьдампа

(0) У тебя в форме обработки нет реквизита с именем «объект»

   Записьдампа

Или его тип не позволяет преобразование, например там строка

   zhukovia

(6) Огромное спасибо.

Недопустимое значение параметра (параметр № 2). При попытке изменить реквизиты организации 1с УНФ

Действительно у меня вместо «Объект» было другое название. Видимо исправил ранее и забыл.

Наведи порядок в своей работе используя конфигурацию 1C «Управление IT-отделом 8»

ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку «Обновить» в браузере.

Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.

Хочу ТЗ добавить колонки почему выдает ошибку

Я
   Genri Тволна — ТЗ на форме; Для ин=1по52цикл ИмяК=»К»+1; Тволна.Колонки.Добавить(ИмяК,Новый ОписаниеТипов(«Число»)); КонецЦикла; ПИШИТ:
{Форма.Форма(286)}: Ошибка при вызове метода контекста (Добавить): Неверное имя колонки Тволна.Колонки.Добавить(ИмяК,Новый ОписаниеТипов(«Число»)); по причине: Неверное имя колонки 
     ДенисЧ

Сообщить(ИмяКолонки) ?

   zbv

Одна из причин: есть уже такая колонка

   Asmody

ошибка тут ИмяК=»К»+1

   Euguln Может все же ИмяК=»К»+ин;    Дуб

(3) +1
(0) ты одноимённую колонку пытаешься вводить, не делая инкремента номера..

   Asmody

пора книгу писать «Миста — как средство групповой отладки»

   Genri (5)это я понял протупил делаю так
ИмяК=»К»+ин;
ПИШИТ:
{Форма.Форма(286)}: Ошибка при вызове метода контекста (Добавить): Неверное имя колонки Тволна.Колонки.Добавить(ИмяК,Новый ОписаниеТипов(«Число»));по причине:    Asmody

плин, ну воткни ты Сообщить(ИмяК); перед Тволна.Колонки.Добавить(); много интересного увидишь

   zbv

(6) +1

(7) добавь проверку на существующие колонки.

   Живой Ископаемый

пишИт

 
 

   Дуб

(9) при грамотном добавлении колонок проверять ничего не надо..

   Genri

(8)Счет идет К1,К2,К3…. но колонки на форме не добавляються.

   zbv

(11) согласен.

   Asmody

а сейчас товарищи объяснят, что «ТЗ на форме» — это небывает

   Genri

(14)В смысле небывает.

   Asmody

(15) в смысле, что на форме у тебя лежит табличное поле, к которому привязана таблица значений.

а это суть разные объекты.

   dimoff

Хорошо когда на 16 дебильных постов один верный, значит не все так плохо, спасибо 4.

   Asmody

(17) для обучения есть два пути: сказать «вот так правильно» и сказать «вот так не правильно». в первом случае обучаемый получит рыбу, а во втором — удочку. разницу чуешь?

   Genri Все, всем спасибо, разобрался…
ТСтат=Новый ТаблицаЗначений; Для ин=1по52цикл ИмяК=»К»+ин; ТСтат.Колонки.Добавить(ИмяК,Новый ОписаниеТипов(«Число»)); КонецЦикла; ЭлементыФормы.ТВолна.Значение=ТСтат; ЭлементыФормы.ТВолна.СоздатьКолонки(); Так работает    ДенисЧ

(17) На 19.

   dimoff

(18) Да, ты тоже прав.

Наведи порядок в своей работе используя конфигурацию 1C «Управление IT-отделом 8»

ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку «Обновить» в браузере.

Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.

   Aswed Пишу так:
&НаСервере
Функция ВернутьДанныеЗадачи(Задача, Сотрудник) Запрос = Новый Запрос; Запрос.Текст = «ВЫБРАТЬ | Задачи.Сотрудник, | Задачи.Задача, | Задачи.Статус, | Задачи.Срочность, | Задачи.ПроцентВыполнения, | Задачи.ТипЗадачи, | Задачи.ДатаПостановкиЗадачи, | Задачи.ДатаВыполненияЗадачи, | Задачи.ОбщееВремяВыполнения, | Задачи.ОбщееВремяВыполненияРеальное |ИЗ | РегистрСведений.Задачи КАК Задачи |ГДЕ | Задачи.Сотрудник = &Сотрудник | И Задачи.Задача = &Задача»; Запрос.УстановитьПараметр(«Задача», Задача); Запрос.УстановитьПараметр(«Сотрудник», Сотрудник); Выборка = Запрос.Выполнить().Выбрать(); Если Выборка.Следующий() Тогда ЗначениеВРеквизитФормы(Выборка.Статус, «Статус»); КонецЕсли; КонецФункции Ругается:»{Документ.ЗакрытиеЗадания.Форма.ФормаДокумента.Форма(78)}: Ошибка при вызове метода контекста (ЗначениеВРеквизитФормы): Недопустимое значение параметра (параметр номер ‘2’) ЗначениеВРеквизитФормы(Выборка.Статус, «Статус»); Что не правильно написал? 
 
   Aswed

UP

   Aswed

Что то очень уж быстро сегодня тонет:(

   Mitriy

а реквизит «Статус» есть?

   Aswed

(3) Есть.

   Aswed

(3) Может где какой флажок поставить надо что бы можно было в него загружать?
ЗЫ Хотя глупо конечно было бы

   Aswed

Уже всю голову себе сломал что я не так сделал

   Mitriy

да вроде нет… это точно реквизит формы, а не объекта?

   Aswed

(7) Мля, точно. Совсем забыл что я его сделал реквизитом объекта! Вот блин тупица!

Спасибо, без тебя бы ещё два часа сидел бы и не мог понять почему именно тут не работает!
Респект!

2 + 2 = 3.9999999999999999999999999999999…

ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку «Обновить» в браузере.

Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.