Каталог временных файлов кластера серверов 1С предприятия

Курс «Администрирование системы «1С:Предприятие 8» в 1С:Учебном центре №1 с 10 по 14 июня 2013 года

Приглашаем вас с 10 по 14 июня 2013 года в 1С:Учебный центр №1 на курс «Администрирование системы «1С:Предприятия 8».

Увеличение масштабируемости прикладных решений «1С:Предприятия 8», возможностей использования различных конфигураций оборудования, операционных систем и типов СУБД привели к тому, что администрирование прикладных решений выделилось в отдельный и достаточно широкий спектр работ, который выполняет собственное ИТ-подразделение или внедренческая компания. Анализ практики администрирования ИТ-инфраструктуры на предприятиях среднего и крупного бизнеса показал, что порой администраторам не хватает практических навыков поиска решений в ситуациях, выходящих за рамки типовых задач, описанных в документации. Нередко системные администраторы или сотрудники сервисной компании ищут методы решения проблем администрирования экспериментальным путем проб и ошибок.

Данный курс позволяет сформировать целостное представление об администрировании системы «1С:Предприятие 8» и выработать практические навыки установки платформы, прикладных решений, серверов защиты, их администрирования и сопровождения с использованием различной инфраструктуры.

Курс предназначен: для сотрудников фирм-франчайзи, занимающихся администрированием информационных сетей, для системных администраторов ИТ-подразделений, сотрудников служб сопровождения сервисных компаний и специалистов по технической поддержке.

В ходе курса слушатели получат систематизированные представления:

  • об установке и настройке операционных систем Windows и Linux;
  • об установке и настройке СУБДMS SQL 2000, Postgree SQL, IBMDB2;
  • о вариантах установки системы «1С:Предприятия 8» и прикладных решений;
  • об инструментах администрирования «1С:Предприятия 8»;
  • о работе системы лицензирования клиентской и серверной части системы «1С:Предприятия 8»;
  • о работе системы «1С:Предприятие 8» под управлением различных операционных систем (Microsoft Windows, Linux);
  • об использовании различных СУБД (Microsoft SQL Server, PostgreSQL, IBMDB2) с системой «1С:Предприятие 8».

На практических занятиях слушатели под руководством преподавателя научатся:

  • производить установку и настройку операционных систем Windows и Linux;
  • производить установку и настройку СУБД (MS SQL Server, PostgreSQL, IBMDB2) под Windows и Linux ;
  • производить установку системы «1С:Предприятие 8»;
  • создавать информационные базы на базе типовых решений;
  • производить настройку кластера серверов системы «1С:Предприятие 8»;
  • настраивать регламентные процедуры для администрирования информационной базы;
  • обновлять приложение и прикладные решения.

Продолжительность курса: 32 академических часа, курс проводится в виде 4-дневного обучения с 10:00 до 17:00 с перерывом на обед и кофе-брейк.

Краткое содержание курса:

  1. Подготовительные работы
  • Системные требования
  1. Технологическая платформа 1С:Предприятия
  2. Сервер баз данных
  • Технические требования к компьютерам
    1. Клиентские компьютеры
    2. Сервер 1С:Предприятия 8
    3. Сервер баз данных
    4. Общие рекомендации

  • Установка операционных систем
    1. Установка операционной системы Windows 2003 c ролью контроллера домена
    2. Установка операционной системы LINUX Fedora 7
  • Установке СУБД для использования с системой 1С:Предприятие 8
    1. УстановкаMicrosoft SQL Server для работы с 1С:Предприятие 8
    2. Обзор установки обновления СУБДMS SQL до Service Pack 4
    3. Установка СУБД Postgree SQL (Windows и Linux)
    4. Установка сервера баз данных IBMDB2 (Windows и Linux)
  • Установка и настройка 1С:Предприятия 8.1 и 8.2
    • Установка и удаление клиентского приложения
    1. Обычная (локальная)
    2. Административная
    3. Использование Групповой политики
    4. Централизованная установка в платформе 1С:Предприятие 8.2
    5. Отличия установки от копирования файлов 1С:Предприятия 8
    6. Совместное использование приложений 8.0, 8.1 и 8.2 различных версий
  • Установка, запуск и удаление кластера серверов 1С:Предприятия 8.1 и 8.2
    1. Установка под управлением операционной системы Windows
    2. Запуск кластера серверов под Windows
    3. Установка под управлением операционной системы Linux
    4. Запуск кластера серверов под Linux
    5. Удаление кластера серверов под Linux
    6. Автоматизация установки и удаления кластера серверов под Linux
  • Установка прикладных решений
    1. Установка шаблонов для общего использования
    2. Установка шаблонов для персонального использования
  • Создание и удаление информационных баз
    1. Управление основным списком информационных баз
    2. Управление списком общих информационных баз и группами
    3. Файловые информационные базы
    4. Клиент-серверные информационные базы
  • Аппаратная защита
    • Виды аппаратных ключей защиты
    • Установка драйвера защиты
    1. Для ОСMS Windows
    2. Для OC Linux
  • Установка и настройка менеджера лицензий
    1. Запуск HASP LicenseManager как приложенияMS Windows
    2. Запуск HASP LicenseManager как службы Windows
    3. Настройка HASP LicenseManager с помощью файла конфигурации (NHSRV.INI)
    4. Настройка 1С:Предприятия 8 для работы с HASP LicenseManager (NETHASP.INI)
    5. Особенности использования нескольких HASP LicenseManager при использовании протокола NetBIOS
    6. Мониторинг лицензий
    7. Особенности работы 1С:Предприятия 8 с несколькими ключами
  • Администрирование
    • Использование механизма заданий
    • Подключение и настройка технологического журнала
    • Примеры настройки технологического журнала
    • Создание дампов аварийного завершения программы в ОС Linux
    • Особенности работы с временными файлами
    • Особенности использования внешнего соединения 1С:Предприятия в WEB-приложениях
    • Настройка параметров брандмауэра Windows XP SP2 для работы 1С:Предприятия 8
    • Разрешение использования TCP порта 445
    • Настройка кластера серверов 1С:Предприятия 8
    1. Управление списком центральных серверов
    2. Управление списком администраторов центрального сервера
    3. Управление списком кластеров центрального сервера
    4. Управление списком администраторов кластера
    5. Управление списком рабочих серверов кластера
    6. Управление списком рабочих процессов
    7. Управление списком информационных баз
    8. Управление списком соединений
    9. Управление списком блокировок
    10. Настройка резервирования кластеров 1С:Предприятия 8.2
    11. Распределение нагрузки на менеджер кластера в 1С:Предприятие 8.2

  • Хранение настроек кластера серверов 1С:Предприятия 8
    1. Рабочий каталог центрального сервера
    2. Рабочий каталог кластера
    3. Рабочий каталог информационной базы
    4. Изменение каталога временных файлов сервера 1С:Предприятия
  • Сохранение параметров настроек пользователя между сеансами
    1. Общее для файлового и клиент-серверного вариантов
    2. Для файлового варианта
    3. Для клиент-серверного варианта
  • Конфигурации 1С:Предприятия 8
    1. Администрирование локальной групповой разработки
    2. Администрирование дистанционной групповой разработки
  • Средства администрирования системы «1С:Предприятие 8»
    1. Тестирование и исправление информационной базы
    2. Тестирование и исправление встроенными средствами
    3. Тестирование и исправление внешними средствами
  • Технология перехода с 1С:Предприятия 8.0 на 1С:Предприятие 8.1 и далее на 8.2
  • Сервисное обслуживание приложения и прикладного решения
    • Обновление приложения
    1. Обновление технологической платформы при обычной установке 1С:Предприятия
    2. Обновление технологической платформы при административной установке 1С:Предприятия
    3. Обновление 1С:Предприятия 8.1 пользователямиMicrosoft Windows без прав администратора
  • Обновление конфигурации, находящейся на поддержке
  • Обработка консоли кластера серверов 1С:Предприятия 8.1
  • Обработка консоли фоновых и регламентных заданий
  • Обработка настройки технологического журнала
  • Обработка консоли журнала регистрации
  • Центр управления производительностью
  • Стоимость курса: 6100 руб. для предприятий-пользователей, 5400 руб. для фирм-партнеров «1С». В стоимость курса включены: обед и методические материалы по данному курсу.

    После обучения выдается свидетельство фирмы «1С» о прохождении данного курса.

    Место проведения курса: г. Москва, 3-й Самотечный пер., д. 23, 1С:Учебный центр №1.

    Онлайн-трансляцию курса (вебинар) можно пройти в учебных классах региональных организаторов по следующему расписанию http://www.1c.ru/rus/partners/training/exitevents/. Онлайн-трансляция обеспечивает сохранение преимуществ очного обучения: общение преподавателя со слушателями в режиме реального времени; оперативность разрешения вопросов, возникающих в процессе обучения; традиционно высокое качество обучения фирмы «1С» (1С:Учебного центра №1). При этом нет дополнительных затрат на проезд и проживание.

    Заявки на обучение просьба заполнять на сайте фирмы «1С»: http://www.1c.ru/rus/partners/training/uc1/course.jsp?id=231.

    По вопросам обучения обращайтесь в 1С:Учебный центр №1 по e-mail: uc@1c.ru или по телефону:
    +7 (495) 688-90-02.

    ]]> Возврат к списку

    Двоичные данные платформы 1С:Предприятие – это универсальный объект встроенного языка программирования для работы с файлами. Благодаря объекту ДвоичныеДанные можно любой файл представить в виде последовательности байт. Объект доступен в тонком клиенте, веб-клиенте, мобильном клиенте, на сервере, толстом клиенте, внешнем соединении, мобильном приложении (клиент/сервер).

    Объект сериализуется

    Данный объект может быть сериализован в/из XML, может использоваться в реквизитах управляемой формы, а также он может быть сериализован в/из XDTO. Тип XDTO, соответствующий данному объекту, определяется в пространстве имен {http://www.w3.org/2001/XMLSchema}. Имя типа XDTO может быть любым из перечисленных: base64Binary, hexBinary.

    Благодаря тому, что двоичные данные доступны и на клиенте, и на сервере, мы можем смело передавать файл в виде двоичных данных с клиента на сервер, однако рекомендованный «шаблон» для передачи файла – использовать хранилище значений.

    Задачи, для решения которых можно использовать двоичные данные:

    • Хранение файлов в базе данных (с использованием ХранилищеЗначения);
    • Передача файла с клиента на сервер;
    • Передача файлов при работе с протоколом HTTP;
    • Передача вложений при работе с электронными письмами;
    • Криптография;
    • Представления файла в виде текста (с использованием Base64).

    Работа с двоичными данными:

    &НаКлиенте Процедура ПередатьФайлНаСервер() Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие); Диалог.МножественныйВыбор = Ложь; Если Диалог.Выбрать() ТОгда БинДанные = Новый ДвоичныеДанные(Диалог.ПолноеИмяФайла); АдресВременногоХранилища = ПоместитьВоВременноеХранилище(БинДанные, ЭтаФорма.УникальныйИдентификатор); ОбработкаФайлаНаСервере(АдресВременногоХранилища); КонецЕсли; КонецПроцедуры &НаСервереБезКонтекста Процедура ОбработкаФайлаНаСервере(АдресВХ) БинДанные = ПолучитьИзВременногоХранилища(АдресВХ); Если БинДанные Неопределено Тогда //БинДанные.Записать(«Путь файла на сервере»); КонецЕсли; КонецПроцедуры

    Данный пример кода показывает, как прочитать двоичные данные и передать их с клиента на сервер, используя объект ДвоичныеДанные.

    Примеры по работе с двоичными данными

    Самый очевидный пример, где применяются двоичные данные, – сохранение файла в базе данных. Для хранения файла в виде двоичных данных необходимо в объекте добавить реквизит с типом «ХранилищеЗначений». Далее представлен пример кода по работе с реквизитом (заполнение значения и получение значения).

    Заполнение:

    ПутьКФайлу = «»; БинДанные = Новый ДвоичныеДанные(ПутьКФайлу); Объект.Файл = Новый ХранилищеЗначения(БинДанные);

    Получение (фрагмент кода, выполняемый на сервере):

    БинДанные = Объект.Файл.Получить(); Если БинДанные Неопределено Тогда // БинДанные.Записать(Имя Файла); // или // Поток = БинДанные.ОткрытьПотокДляЧтения(); КонецЕсли

    Рассмотрим еще один пример: скачивание картинки из интернета и отображение ее на управляемой форме. Для этого также добавляем реквизит с типом ХранилищеЗначения, в котором будет помещаться картинка в двоичном формате.

    Рис.1 Скачивание картинки из интернета

    Функция, скачивающая картинку из интернета:

    Функция СкачатьКартинку(URL) СтруктураURI = ОбщегоНазначенияКлиентСервер.СтруктураURI(URL); ФайлОтвет = ПолучитьИмяВременногоФайла(); HTTPСоединение = Новый HTTPСоединение(СтруктураURI.ИмяСервера); HTTPЗапрос = Новый HTTPЗапрос(СтруктураURI.ПутьНаСервере); Ответ = HTTPСоединение.Получить(HTTPЗапрос, ФайлОтвет); Если Ответ.КодСостояния = 200 Тогда Возврат Новый ДвоичныеДанные(ФайлОтвет); КонецЕсли; КонецФункции

    Использование функции:

    БинДанные = СкачатьКартинку(«url картинки»); СпрОбъект.Аватар = Новый ХранилищеЗначения(БинДанные); СпрОбъект.Записать();

    Теперь у нас в реквизите «Аватар» лежат двоичные данные картинки. Чтобы картинку вывести на управляемую форму, необходимо добавить реквизит формы «Тип строка», перекинуть его на форму (drag-and-drop), либо создать самостоятельно элемент формы, указав в поле «Путь к данным» наш реквизит «Картинка», после чего изменить вид на «Поле картинки».

    Рис.2 Поле картинки

    По событию ПриСозданииНаСервере

    СпрОбъект = РеквизитФормыВЗначение(«Объект»); Картинка = ПолучитьНавигационнуюСсылку(СпрОбъект, «Аватар»);

    Готово, на форме у нас картинка.

    Двоичные данные и потоки

    Говоря о двоичных данных, стоит упомянуть о возможности работы с потоками. Она появилась относительно недавно, а именно в версии 8.3.9. Чтобы потоком можно было читать из двоичных данных, применяется метод ОткрытьПотокДляЧтения. Допустим, у нас в базе данных лежит заархивированный xml-файл (как хранить файлы в базе данных рассматривалось ранее). Нам нужно вывести пользователю содержимое этого файла, или у вас настроен какой-то обмен, и вы передаете файлы в заархивированном виде (для экономии трафика).

    Последовательность действий при работе с двоичными данными без использования потоков:

    • Получить двоичные данные из базы;
    • Записать их во временный файл;
    • Разархивировать;
    • Удалить временный файл;
    • Прочитать разархивированный файл.

    Последовательность действий при работе с потоками:

    • Получить двоичные данные из базы;
    • Открыть поток для чтения;
    • Разархивировать;
    • Прочитать разархивированный файл.

    Пример кода без использования потоков:

    Процедура ОбработкаФайлаНаСервере(АдресВХ) БинДанные = ПолучитьИзВременногоХранилища(АдресВХ); ВрФайл = ПолучитьИмяВременногоФайла(«zip»); Если БинДанные Неопределено Тогда БинДанные.Записать(ВрФайл); ПолучитьФайлыАрхива(ВрФайл); УдалитьФайлы(ВрФайл); КонецЕсли; КонецПроцедуры Функция ПолучитьФайлыАрхива(ВрФайл) Результат = Новый Массив(); ЧтениеZipФайла = Новый ЧтениеZipФайла(ВрФайл); ЧтениеZipФайла.ИзвлечьВсе(«Путь к каталогу», РежимВосстановленияПутейФайловZIP.Восстанавливать); ЧтениеZipФайла.Закрыть(); КонецФункции

    Пример кода по работе с потоком:

    Процедура ОбработкаФайлаНаСервере(АдресВХ) БинДанные = ПолучитьИзВременногоХранилища(АдресВХ); Если БинДанные Неопределено Тогда ПолучитьФайлыАрхива(БинДанные); КонецЕсли; КонецПроцедуры Функция ПолучитьФайлыАрхива(БинДанные) Результат = Новый Массив(); ЧтениеZipФайла = Новый ЧтениеZipФайла(БинДанные.ОткрытьПотокДляЧтения()); ЧтениеZipФайла.ИзвлечьВсе(«Путь к каталогу», РежимВосстановленияПутейФайловZIP.Восстанавливать); ЧтениеZipФайла.Закрыть(); КонецФункции

    Если диск у вас на SSD, рекомендую использовать потоки не только в примере с архивацией, а везде, где это возможно. Да, в данном примере все же происходит запись на диск (разархивация), но будем надеяться, когда-нибудь 1С реализует метод двоичных данных ОткрытьПотокДляЗаписи.

    Работа с Base64

    Base64 – это стандарт, позволяющий кодировать двоичные данные в виде строки (для кодирования используется 64 символа таблицы ASCII, отсюда и название). Тип ДвоичныеДанные сериализуем, то есть его можно представить в виде XML, для этого применяется объект встроенного языка СериализаторXDTO. После сериализации данные представлены одним узлом base64Binary, содержимое которого есть последовательность байт, закодированная в формате Base64.

    xmlns:xsi=»»>http://www.w3.org/2001/XMLSchema-instance»>

    строка в Base64

    Платформа 1С также позволяет кодировать двоичные данные, не прибегая к сериализации. Для этого есть две функции:

    = Base64Строка()

    и

    = Base64Значение()

    Они преобразуются в Base64 и обратно в двоичные данные.

    Если у вас остались вопросы по работе с двоичными данными в среде 1С:Предприятие, обратитесь к нашим специалистам и получите консультацию по 1С 8.3 или воспользуйтесь услугами по сопровождению 1С.