Как базу 1С скинуть на флешку

Иногда возникают ситуации, когда необходимо сделать копию информационной базы 1С 8.3 и записать ее на флеш-носитель, чтобы перенести базу на другой компьютер, сделать копию при переустановке операционной системы или просто для ее хранения на флешке, чтобы более обезопасить себя.

Как выгрузить базу 1С 8.3 на флешку

Для выполнения этого действия зайдем в Конфигуратор нашей информационной базы (ИБ). В меню Администрирование выберем пункт Выгрузить информационную базу.

В окне указываем путь выгрузки и задаем имя файла. Файл выгружается в формате *.dt — это архивная копия базы в формате 1С. Далее у нас два варианта.

Первый вариант — мы можем при указании пути файла сразу задать, что мы выгружаем данные на флешку. При нажатии кнопки Сохранить будет произведена выгрузка непосредственно туда.

Второй вариант — мы выгрузим наши данные в папку компьютера, например в папку Архив 1С, а уже потом перенесем ее на флешку. В этом случае, мы указываем путь к нашей архивной папке (или другому месту выгрузки).

По окончании выгрузки программа 1С 8.3 выдаст сообщение.

После чего, перейдем в нашу папку с сохраненным файлом. В нашем примере Мой компьютер — Диск С — Архив 1С.

Для того чтобы перенести файл нашей архивной копии на флешку, нажмем на нем правой кнопкой мышки и открыв пункт меню Отправить выберем наш съемный носитель, в нашем случае он называется — Флешка (Н:).

Файл будет скопирован на флеш-носитель.

Загрузка базы 1С 8.3 с флешки через Конфигуратор

Загрузка файла, выгруженного через Конфигуратор производится также через пункт меню Администрирование — Загрузить информационную базу.

В открывшемся окне, переходим к нашей флешке и выбираем сохраненный файл. В нашем примере 1Cv8.

Нажимаем кнопку Открыть и ждем окончания загрузки.

Как скачать базу 1С 8.3 на флешку

Иногда возникают ситуации, когда требуется просто перенести на флешку (или съемный диск) информационную базу 1С 8.3 и подключить ее на другом компьютере, например для просмотра данных при проведении ревизии вышестоящей организацией, проверки контролирующими органами, если есть необходимость воспользоваться базой.

Иногда требуется перенести базу 1С 8.3 на съемный диск для работы не в офисе, а дома. Хотя вариант работы с информацией с флешки небезопасен, неправильное извлечение флешки или сбой может привести к потере данных или сбою в работе программы 1С. Альтернатива такой работы — это работа в 1С в облаке .

Но все же рассмотрим этот вариант. Для этого нам нужно знать, где располагается наша база 1С 8.3. Это видно в нижней части окна запуска программы. Для отображения этой информации необходимо выделить название базы.

Найдем папку с нашей информационной базой.

Перед тем как скопировать ее на флешку, надо убедиться, что информация помещается на флешку, для этого нажмем правой кнопкой мышки на папке с ИБ, откроем пункт меню Свойства и посмотрим ее объем.

Далее, нажав на папке правой кнопкой мышки выбираем пункт меню Отправить и выбираем наш съемный носитель, в нашем примере Флешка (Н:).

Наша папка с информационной базой 1С 8.3 отправлена на флешку. Дожидаемся окончания копирования и извлекаем флешку в безопасном режиме.

Как загрузить базу в 1С 8.3 с флешки

Для подключения и просмотра информационной базы 1С 8.3 с флешки в окне запуска программы 1С Предприятие нажмем кнопку Добавить.

В окне добавления информационной базы установим переключатель в положение Добавление в список существующей информационной базы.

Нажав кнопку Далее, пишем название нашей базы и указываем путь к ней.

В нашем случае она размещена на Флешке (Н:). Нажимаем кнопку Выбор папки.

Указываем параметры запуска (можно оставить по умолчанию).

И нажимаем кнопку Готово и наша информационная база 1С 8.3, установленная с флешки, готова к использованию.

Напомним о том, что нельзя извлекать флешку пока открыта программа 1С, иначе возможно ее повреждение и база может впоследствии не запуститься.

См. также:

  • Как перенести 1С 8.3 на другой компьютер с сохранением лицензии
  • Как выгрузить документ, отчет из 1С 8.3 в Excel
  • Резервное копирование 1С 8.3 Бухгалтерия 3.0
  • Как создать информационную базу в 1С 8.3

Если Вы еще не являетесь подписчиком системы БухЭксперт8:

Активировать демо-доступ бесплатно →

или

Оформить подписку на Рубрикатор →

После оформления подписки вам станут доступны все материалы по 1С Бухгалтерия, записи поддерживающих эфиров и вы сможете задавать любые вопросы по 1С.

Помогла статья?

Получите еще секретный бонус и полный доступ к справочной системе БухЭксперт8 на 14 дней бесплатно

Случается, что при работе с программой 1С возникает подобная ошибка — ошибка блокировки данных:

Рис.1 Распространенная ошибка

Чаще всего данное предупреждение конфигуратора возникает при выгрузке информационной базы или при обновлении конфигурации 1С. Для того чтобы исправить сложившуюся ситуацию и запустить работу конфигурации, в первую очередь необходимо выяснить причины ошибки исключительной блокировки информационной базы. Это может быть одна из следующих причин:

  • Пользователи не вышли из системы 1С

Для начала необходимо посмотреть все активные сеансы пользователей. Активных пользователей можно посмотреть в конфигураторе 1С так: нажать кнопку Администрирование, затем выбрать Активные пользователи. И попросить их выйти из системы. Также информацию о блокирующих сеансах обычно можно получить из самого окна с ошибкой.

  • У пользователя запущена база 1С, но не введен пароль

В таком случае у пользователя остается висеть подобное окно:

Рис.2 У пользователя запущена база 1С, но не введен пароль

Сеанс такого пользователя найти сложнее, так как он не отображается в окошке Активные пользователи. Более того, информация об ошибке не содержит какой-либо полезной информации:

Рис.3 Информация об ошибки

Такого рода ошибка характерна для файловых информационных баз. Необходимо найти подобные процессы с помощью диспетчера задач, и, используя его же, принудительно их завершить.

  • Зависшие сеансы

Все пользователи вышли, а сообщение об ошибке остается прежним, значит, скорее всего, есть зависшие сеансы. Для таких зависших сеансов требуется принудительное завершение. Это рекомендуется делать аккуратно, прибегая к этому методу только тогда, когда не получаются все остальные.

Способы завершения зависших сеансов в файловом варианте

  • С помощью Диспетчера задач. При завершении сеансов информация у пользователей, работающих в системе, может не сохраниться, и важные данные могут быть потеряны. Завершить сеансы данным способом можно так: вызвать диспетчер задач (Ctrl+Alt+Delete), затем нажать снять задачу, затем завершить процесс. Процессы 1С называются 1cv8.exe или 1cv8c.exe.

Рис.4 Диспетчер задач

  • Перезагрузить сервер, на котором установлена файловая система 1С

Способы завершения зависших сеансов в клиент-серверном варианте

В первую очередь, необходимо попробовать удалить сеансы через консоль администрирования серверов, найдя в ней нужную базу и зайдя в меню Сеансы*.

  • Выделить нужные зависшие сеансы и удалить их через пункт контекстного меню;

Рис.5 Меню Сеансы

*Если в меню Сеансы нет сеансов, их стоит поискать в меню Соединения. И попробовать аналогично удалить.

  • Если не удалось удалить сеансы, используя консоль, то необходимо перезапустить службу Агент сервера 1С:Предприятия 8.3.
  • Если все предыдущие способы не решили проблему и зависшие сеансы так и остались на своих местах, то в качестве крайней меры необходимо перезагрузить сервер.

Зависшие фоновые задания в клиент-серверном варианте

В клиент-серверном варианте частым источником возникновения ошибки исключительной блокировки информационной базы являются повисшие фоновые задания.

Неприятной особенностью этого явления также является и то, что зачастую их очень тяжело удалить. Обычно эти задания можно увидеть в консоли администрирования на вкладке Соединения, но при попытке их удаления они появляются вновь.

Чтобы их удалить можно попробовать следующие способы:

  • Удалить их несколько раз подряд и проверить, не появляются ли они вновь.
  • В свойствах базы установить флаг Блокировка регламентных заданий включена, и после этого еще раз попробовать удалить зависшее задание.

Рис.6 Блокировка регламентных заданий включена

Таким образом, при возникновении такой проблемы, как ошибка исключительной блокировки информационной базы, главным шагом становится выяснение причины возникновения проблемы, поскольку выбор способа ее устранения, в частности, среди описанных в данной статье, зависят от этого. То есть не стоит торопиться перегружать сервер сразу же, для начала надо попробовать решить проблему более «гуманным» образом.

Код 1C v 8.х // Параметры
// Хранилище – ХранилищеЗначения, которое содержит объект типа
// ДвоичныеДанные с файлом для записи на диск.
// ИмяФайла – Строка, содержащая полное имя файла.
// ТолькоЧтение – Булево, признак установки записываемому файлу атрибута ТолькоЧтение.
// СпособПерезаписи – Строка. Параметр определеляет способ перезаписи существующих
// файлов на диске. В зависимости от пришедшего параметра выдается или
// не выдается запрос на перезапись файлов. Может устанавливаться в теле
// функции, если это необходимо. Принимаемые значения:
// «» (пустая строка) — это означает, что диалог еще ни разу не задавался
// и при наличии существующего файла будет выдан диалог запроса перезаписи.
// ДА — предыдущий файл был перезаписан, но перезапись текущего надо
// запросить снова
// НЕТ — предыдущий файл не был перезаписан, но перезапись текущего надо
// запросить снова
// ДАДЛЯВСЕХ — предыдущий файл был перезаписан, и все последующие тоже
// надо перезаписывать.
// НЕТДЛЯВСЕХ — предыдущий файл не был перезаписан, и все последующие тоже
// не надо перезаписывать.
//
// Возвращаемое значение:
// Булево – Истина, если каталог выбран, Ложь, если нет.
//
Функция СохранитьФайлНаДиске(Хранилище, ИмяФайла, ТолькоЧтение, СпособПерезаписи, ВопросОПерезаписи = Истина, ИмяСправочника = «удХранилище») Экспорт
Попытка
ФайлНаДиске = Новый Файл(ИмяФайла);
КаталогНаДиске = Новый Файл(ФайлНаДиске.Путь);
Если Не КаталогНаДиске.Существует() Тогда
СоздатьКаталог(ФайлНаДиске.Путь);
КонецЕсли;
Если ФайлНаДиске.Существует() И ВопросОПерезаписи = Истина Тогда
Если СпособПерезаписи = «»
ИЛИ Врег(СпособПерезаписи) = «ДА»
ИЛИ Врег(СпособПерезаписи) = «НЕТ» Тогда
ФормаЗапросаПерезаписиФайлов = Справочники.ПолучитьФорму(«ФормаЗапросаПерезаписиФайлов»);
ФормаЗапросаПерезаписиФайлов.ТекстПредупреждения =
«На локальном диске уже существует файл:
|» + ИмяФайла + »
|Перезаписать имеющийся файл?»;
СпособПерезаписи = ФормаЗапросаПерезаписиФайлов.ОткрытьМодально();
Если СпособПерезаписи = Неопределено
ИЛИ Врег(СпособПерезаписи) = «НЕТ»
ИЛИ Врег(СпособПерезаписи) = «НЕТДЛЯВСЕХ» Тогда
Возврат Ложь;
КонецЕсли;
ИначеЕсли Врег(СпособПерезаписи) = «НЕТДЛЯВСЕХ» Тогда
Возврат Ложь;
КонецЕсли;
// Если существующему файлу установлено ТолькоЧтение, отменим эту установку.
Если ФайлНаДиске.ПолучитьТолькоЧтение() Тогда
ФайлНаДиске.УстановитьТолькоЧтение(Ложь);
КонецЕсли;
КонецЕсли;
// Остались случаи когда:
// — пользователь ответил Да или ДаДляВсех в текущем диалоге
// — способ перезаписи уже пришел со значением ДаДляВсех
Если ТипЗнч(Хранилище) <> Тип(«ДвоичныеДанные») Тогда
ДвоичныеДанные = Хранилище.Получить();
Иначе
ДвоичныеДанные = Хранилище;
КонецЕсли;
ДвоичныеДанные.Записать(ИмяФайла);
ФайлНаДиске.УстановитьТолькоЧтение(ТолькоЧтение);
Исключение
Предупреждение(ОписаниеОшибки());
Возврат Ложь;
КонецПопытки;
Возврат Истина;
КонецФункции
Информация взята с сайта http://helpf.pro