6 НДФЛ в зуп

В 1С весь пользовательский интерфейс построен на формах. Для того чтобы наглядно в этом убедиться достаточно открыть любой документ или справочник. Формы создаются в режиме 1С:Конфигуратор. Для их создания необходимо обладать знаниями в области программирования 1С. Очень часто перед обработой данных с формы требуется выполнить проверку на заполненность обязательных полей. Это можно сделать несколькими способами.

Встроенные методы проверки заполнения

Во встроенном языке 1С есть функция для автоматической проверки заполнения полей формы. Функция ПроверитьЗаполнение() проверяет заполнение реквизитов у которых свойство "Проверка заполнения" установлено в значение "Показывать ошибку". Если реквизит не заполнен, то выводится сообщение об ошибке.

Свойство "Проверка заполнения" можно установить в двух местах:

1) В свойствах реквизита формы

2) В свойствах реквизита объекта метаданных (справочника, документа и т.д)

Процедура ВыполнитьНажатие()

ЕслиНЕ ПроверитьЗаполнение()Тогда
Возврат;
КонецЕсли;

//…
//…
//…

КонецПроцедуры

Программная проверка заполнения

Встроенный язык программирования обладает всеми необходимыми возможностями для того чтобы написать проверку на заполненность полей формы.

Как нужно правильно формировать отчет 6 НДФЛ в программе 1С: ЗУП

В основном, для проверки заполнения используется несколько функций. Для проверки ссылочных значений применяется встроенная функция Пустая(), которая вызывается непосредственно из ссылки. Для проверки строковых значений подходит функция ПустаяСтрока(<Строка>). Есть более универсальный метод ЗначениеЗаполнено(<Значение>), он проверяет заполненность значений любых типов. Информацию о том как работает та или иная функция можно найти в синтакс-помощнике.

Процедура ПроверитьЗаполнение()

//Проверка ссылочных знаечний
Если Номенкалтура.Пустая()Тогда
Сообщить("Номенлатура пустая ссылка");
КонецЕсли;

//Проверка строковых знаечний
Если ПустаяСтрока(Артикул)Тогда
Сообщить("Строка пустая");
КонецЕсли;

//Проверка с помощью функции ЗначениеЗаполнено()
//Булево значение всегда заполнено
//Строка не пустая, если в строке есть непробельные символы
//Массив или коллекция не пустая, если в них есть хотя бы 1 элемент
//Неопределено и Null это всегда пустые значения
ЕслиНЕ ЗначениеЗаполнено(Номенкалтура)Тогда
Сообщить("Номенлатура пустая ссылка");
КонецЕсли;

ЕслиНЕ ЗначениеЗаполнено(Артикул)Тогда
Сообщить("Строка пустая");
КонецЕсли;

КонецПроцедуры

Заполнение отчета 6-НДФЛ в ЗУП 2.5 и ЗУП 3.0 от 26.10.2016

Форма 6-НДФЛ и порядок ее заполнения утверждены приказом ФНС от 14.10.2015 № ММВ-7-11/450@. На сегодняшний день еще остались нерешенные моменты по её заполнению. Рассмотрим разъяснения ФНС, которые реализованы в программных продуктах 1С при составлении отчетности за 9 месяцев 2016г. Так же рассмотрим заполнение отчета 6-НДФЛ в программных продуктах 1С:Зарплата и Управление Персоналом в редакции 2.5 и 3.0 (далее ЗУП 2.5, ЗУП 3.0) и объясним, в каких моментах автоматическое заполнение 6-НДФЛ в ЗУП 2.5 и УПП 1.3. не будет реализовано (блок учета заработной платы ЗУП 2.5 аналогичен блоку в УПП 1.3.).

Обратим внимание на важные моменты по письму ФНС России от 01.08.2016 N БС-4-11/13984@:

  1. Изменился учет срока перечисления налога при заполнении раздела 2: соблюдение иерархического списка производится по строке 120 (срок перечисления налога).
  2. Освещена новая позиция ФНС по заполнению раздела 2: анализируется в какой налоговый период относится срок перечисления налога, в такой и отчетный период эта операция и включается.
  3. Изменилось отражение доходов сотрудников, если исчисленный по ним налог полностью перекрывается авансовым платежом, либо получился с нулевым значением, если вычет больше дохода. Ранее для таких доходов создавались блоки, где были заполнены только показатели по строкам 100 и 130. Сейчас эти доходы будут привязаны к датам основных выплат, тем самым сворачиваясь с аналогичным блоком с ненулевым удержанным налогом т.е. общее количество блоков будет уменьшено.

Заполнение 6-НДФЛ в ЗУП 3.0

Разработчики модернизировали алгоритм заполнения строки 130 (сумма фактически полученного дохода) раздела 2 в программе ЗУП 3.0. За 1 полугодие в отчете заполнение данной строки производилось динамически: расчет суммы для строки 130 в момент заполнения 6-НДФЛ. При заполнении отчета за 9 месяцев расчет суммы для строки 130 производится в момент удержания НДФЛ (доход рассчитывается для сотрудников, включенных в ведомость по которым: проводится выплата дохода и удержание НДФЛ) и запись в регистр «Расчеты налогоплательщиков с бюджетом по НДФЛ». Новый алгоритм работает только для документов, проведенных в новом релизе для ЗУП 3.0 это 3.0.25.138. Для документов, проведенных, до обновлений работает старый алгоритм заполнения строки 130. Для работы нового алгоритма для всех документов за 9 месяцем требуется раз провести все документы выплаты за период и перепровести все документы начисления и провести документы выплаты. Благодаря новому алгоритму программа определяет сроки перечисления для зарплаты, выплачиваемой с отпускными правильно (ранее срок определялся как конец месяца выплаты, а не следующий после выплаты день, если в ведомости на выплату сумма основного заработка и отпускных/больничных перечислялась общей суммой).

Новые возможности для 6-НДФЛ в ЗУП 3.0

  1. Появился отчет «Проверка разд.2 6-НДФЛ». Позволяет проверить сумму налога, сумму полученного дохода в разрезе дат (дата получения дохода, срок перечисления, дата удержания налога).
  2. Возможность рассчитывать и выплачивать зарплату вместе с отпуском. Программа определяет сроки перечисления для зарплаты, выплачиваемой с отпускными/больничными общей суммой правильно (ранее срок определялся как конец месяца выплаты, а не следующий после выплаты день по документу основания). Теперь срок определяется по коду дохода: 2012 (отпускные), 2300 (больничные) — конец месяца выплаты, остальные доходы — следующий после выплаты день.
  3. Применение стандартных вычетов на детей задним числом. Например, сотрудник написал заявление на вычет не с начала года. Теперь по строке 130 раздела 2 программа верно указывает сумму дохода за месяц, в котором отразилась применение всех вычетов с начала года. Ранее сумма рассчитывалась арифметическим путем в обратном порядке от суммы налога.

Заполнение 6-НДФЛ в ЗУП 2.5

На партнерском семинаре 1С было озвучено то, что в программе ЗУП 2.5 (соответственно и в УПП 1.3) заполнение отчета 6-НДФЛ производится по старому алгоритму сбора данных для строки 130. Строка 130 рассчитывается динамически в момент заполнения отчета из-за отсутствия связи начислений и выплат (не распознается вид дохода зарплата, больничный, отпускные), что приводит к необходимости расчета «фактически полученного дохода» в момент заполнения 6-НДФЛ исходя из суммы удержанного налога (из-за этого может быть искажение фактически начисленного дохода).

На сегодняшний момент разработчики рекомендуют использовать вариант учета удержанного НДФЛ «Принимать исчисленный НДФЛ к учету как удержанный». При использовании данного учета не зависит от момента проведения документов по выплате зарплаты. Дата выплаты зарплаты устанавливается в документе расчета заработной платы. Но есть свои ограничения при использовании данного учета, такие как:

  • Нельзя использовать данную настройку, если зарплата выдается частями
  • Удержание НДФЛ с натуральных доходов регистрируется сразу в день выдачи дохода

Для тех, у кого снят флажок «Принимать исчисленный НДФЛ к учету как удержанный», удержание налога осуществляется при выплате зарплаты, поэтому важно жестко соблюдать хронологию проведения документов: начисление — выплата. Если на момент выплаты аванса есть проведенные документы, по которым выплата не производилась, ведомость на выплату аванса или ведомость на межрасчетные выплаты производит удержание НДФЛ и в отчете 6-НДФЛ даты получения дохода и перечисление налога формируются неверно. Как рекомендуют разработчики программы, если выплата по документу начисления не производилась, то документ лучше не проводить до формирования ведомости на выплату.

В программе ЗУП 2.5 разработан инструмент «Изменение порядка учета документов» (в меню «Расчет зарплаты по организации» — «Налоги и взносы» — «Изменение порядка учета документов»). С помощью этого инструмента можно попытаться восстановить хронологию документов.

"1С Зарплата и Управление Персоналом" в примерах!

Но есть небольшой плюс при использовании варианта учета удержанного НДФЛ при выплате зарплаты — данный вариант поддерживает выплату зарплаты частями. Удерживается та доля налога, которая соответствует фактически полученному (выплаченному) доходу из всего начисленного к выплате.

В программе ЗУП 2.5 срок перечисления дохода (строка 140 раздел 2) при использовании упрощенного учета НДФЛ определяется по документу начисления, а при использовании варианта учета удержанного НДФЛ при выплате зарплаты определяется по характеру ведомости, поэтому необходимо обязательно разделять выплаты (зарплата, отпускные, пособия по больничным листам).

Что придется корректировать вручную в ЗУП 2.5:

  1. Ошибочно уменьшаются доходы в строке 130 из-за вычетов примененных задним числом. В ЗУП 3.0 автоматизировано (ошибок нет), в ЗУП 2.5 придется откорректировать ситуации в ручную.
  2. Не автоматизировано заполнение сроки 130 в случае сторнирования вычетов и доначисления дохода.
  3. Не автоматизировано заполнение строки 130 для сумм налога, доначисленного в результате «переноса вычетов с больничного на зарплату» и в случае сторнирования вычетов и до начисления налога.

На основании выше изложенной информации — рекомендуем пользователям ЗУП 2.5 переходить на ЗУП 3.0, т.к.

  • 6-НДФЛ в ЗУП 2.5. авоматически заполняться на 100% не будет
  • Поддержка конфигурации и выпуск обновлений для ЗУП 2.5 может быть прекращен в конце 2016 года

Для УПП 1.3 при большом объеме информации на текущий момент можем порекомендовать выполнять доработки программы, которые позволят облегчить ручной сбор 6-НДФЛ.

Компания СИТЕК оказывает услуги по переходу с ЗУП 2.5 на ЗУП 3.0, предлагаем Вам ознакомиться с Тарифными планами на наши услуги.

____________________________________________________________

Автор статьи: Специалист отдела сопровождения — Никитина Елена. Дата обновления статьи 26.10.2016